WordPress Gutenberg 5.0

WordPress Gutenberg 5.0

WordPress heeft onlangs een major update uitgebracht. De WordPress 5.0 ‘Gutenberg’ update. In dit artikel vertel ik je wat deze update inhoudt en of je moet updaten.

De grootste update binnen de Gutenberg update is de nieuwe editor (die voornamelijk op basis van blokken werkt). De weken voorafgaand aan de lancering van de WordPress Gutenberg update was dit al te testen. Er was veel kritiek over de update op diverse forums.

JKC Media Artikel - Gutenberg

Het zou namelijk nog lang niet compatible zijn met veel andere plugins. Waaronder ‘visual composer’ (wat u wellicht ook op je eigen website heeft).

Daarnaast is er ook (zoals gebruikelijk) een nieuw WordPress thema uitgekomen genaamd ‘Twenty Nineteen’. Die helemaal geoptimaliseerd is voor de nieuwe Gutenberg editor volgens WordPress.

Waar komt de naam Gutenberg vandaan en hoezo is deze update van WordPress ernaar vernoemd?

De Duitse Johannes Gutenberg is de uitvinder van de ‘boekdrukkunst’. Hij is het meest bekend om zijn ‘Gutenbergbijbel’ die hij in 1455 had uitgebracht.

De reden waarom WordPress 5.0(.x) is vernoemd naar (Johannes) Gutenberg is omdat dankzij zijn uitvindingen in de boekdrukkunst het makkelijker en toegankelijker was voor veel meer mensen om massale verspreidingen van publicaties te verspreiden.

Hoe werkt de nieuwe editor dan?

Tot op heden hadden we de bekende ‘TinyCME editor’ voor WordPress versies t/m 4.9.8. Vaak had je dan met plugins zoals ‘Advanced Custom Fields’ en/of ‘Visual Composer’ de mogelijkheid om je pagina te bewerken en in te delen.

De Gutenberg editor heeft dit zelf ingebouwd. Het is eigenlijk gebaseerd op ‘blokken’ zoals ze zelf hebben aangekondigd in WordPress hun blog. Je kan dan bijvoorbeeld een ‘paragraph block’ toevoegen aan je website of een ‘button block’.

Is het handig om hiermee zelf gemakkelijk een website te maken? Kort antwoord: Ja. Maar is het ook handig? Nee. Er zijn nog niet heel veel blocks binnen de Gutenberg editor en daardoor kan je website er erg standaard uit zien.

Moet ik nu updaten?

Ik raad je aan om voorlopig nog even niet up te daten (zeker niet op een live website). Momenteel zijn de meeste plugins nog niet (volledig) compatible met de nieuwe update en dat kan ervoor zorgen dat je website ‘breekt’.

Daarnaast zijn er ook al veel bugs ontdekt in WordPress 5.0, veel mensen verwachten dat deze bugs zijn opgelost in WordPress 5.0.1.

Justin van Dongen van JKC Media B.V. heeft dit artikel mogen schrijven. JKC Media B.V. is een internetbureau gespecialiseerd in WordPress.

Mocht je meer artikelen van mij willen lezen, bekijk dan gerust onze website via https://www.jkc-media.nl.

Justin-Van-Dongen
Tags:
Geen reactie's

Geef een reactie

vijf × 1 =

error: